파이썬 3.5 이용 중 pip 업데이트 오류 해결방법

파이썬 3.5 이용 중 pip 업데이트 오류 해결방법

Summary:

pip install --upgrade pip으로 pip 버전 업데이트 시 발생하는 오류 해결방법입니다. 맥OS(버전 10.12.3), 파이썬 3.5 기준으로 작성되었습니다.


pip install –upgrade pip

파이썬에 lxml 모듈을 설치하기 위해 pip 명령어를 썼는데 터미널에서 pip을 업그레이드하라고 했다.

You are using pip version 8.1.2, however version 9.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

시키는 대로 pip install --upgrade pip을 입력했다. 온통 빨간색이다. 난 파이썬 3을 쓰는데 맥 기본 파이썬 저장장소인 2.7이 있는 곳에 pip을 깔려고 하다 보니 오류가 생긴 것 같다.


pip3 install –upgrade pip

맥 터미널에서 파이썬3을 실행시킬 때 python test.py가 아니라 python3 test.py라고 쓰는 것처럼 pip도 pip 말고 pip3 install --upgrade pip을 썼어야 했다.

이렇게 오류 없이 Successfully installed pip-9.0.1 이라는 메세지가 뜨면 성공이다.


추가 팁: pip 업데이트 뒤 모듈 설치하기

맥 파이썬을 이용중이라면 pip로 모듈을 설치하는 게 가장 편하다. 설치할 때는 터미널을 열고 바로 아래와 같이 입력한다. sudo는 모듈 설치 어드민 권한을 위해 앞에 붙인다. 설치가 아닌 업그레이드를 하는 거라면 sudo를 빼고 pip3 install --upgrade lxml을 입력하고 엔터를 누른다. (lxml 대신 설치하고자 하는 모듈 이름을 입력하면 된다.)

sudo pip3 install lxml
pip3 install --upgrade lxml


Hyeyeon

A Blog about E-Commerce and Product Management

comments powered by Disqus

    rss facebook twitter github youtube mail spotify instagram linkedin google google-plus pinterest medium vimeo stackoverflow reddit quora